Даунгрейд php7 до php5.6 в Ubuntu16.04

Небольшая короткая заметка о том что уже наболело.

Как вы знаете, вышел php7, а с выходом Ubuntu16.04 php7 в репозиториях идет по умолчанию. Но если у вас есть сайты, которые корректно работают только с версией php5.6, то дело дрянь.. Но выход есть.

Для начала отключите proxy_fcgi, так как он нам не нужен, а с ним могут быть проблемы..

sudo a2dismod proxy_fcgi proxy; sudo service apache2 restart

Далее подключаем необходимый репозиторий, делаем apt update и устанавливаем php5.6, php5.7 и libapache2-mod-php и другие необходимые модули:

sudo add-apt-repository ppa:ondrej/php<br />
sudo apt-get update<br />
sudo apt-get install php7.0 php5.6 php5.6-mysql php-gettext php5.6-mbstring php-xdebug libapache2-mod-php5.6 libapache2-mod-php7.0

Все. У вас стоят две версии php. Теперь, если вам необходимо работать в php7, делайте следующее:

Для Apache:

sudo a2dismod php5.6; sudo a2enmod php7.0; sudo service apache2 restart

Для CLI:

update-alternatives --set php /usr/bin/php7.0

Для того чтобы запустить версию php5.6:

Для Apache:

sudo a2dismod php7.0; sudo a2enmod php5.6; sudo service apache2 restart

Для CLI:

sudo update-alternatives --set php /usr/bin/php5.6

Вот и все =)

Source: askubuntu.com/questions/761713…